UMTS的完整性保护是在PDCP层来完成的吗?

问题已开启 普通问题 提问者:aoshicanglong|提问时间:2012-04-23

我要回答

请先 登录 或 注册 再回答问题

问题答案 (1)

PDCP(Packet Data Convergence Protocol)分组数据汇聚协议

知1fkjhfjouiK:JFD()$#_*(本文来自移动通信网www.mscbsc.com,版权所有
  PDCP 是对分组数据汇聚协议的一个简称。 它是UMTS中的一个无线传输协议栈, 它负责将IP头压缩和解压、传输用户数据并维护为无损的无线网络服务子系统(SRNS)设置的无线承载的序列号。 我)$#@3K:JFD()本文来自移动通信网www.mscbsc.com,版权所有
  压缩技术可以根据二者之一 RFC 2507 或 RFC 3095. RFC 1144年 罐头为一些背景知识也使用,并且,虽然技术在RFC没有用于现代 TCP/IP 实施,它仍然显示什么压缩或解压技术看似。
  如果 PDCP 配置为 没有压缩 它将送IP小包,不用压缩,它根据它的配置将压缩小包由上层并且附有a PDCP 倒栽跳水和送小包。 它使用更低的层数提供的服务称Radio键路控制(RLC)。
  PDCP 倒栽跳水包括二个领域: PID和PDU类型。
  PDU类型 领域表明PDU是否是数据PDU或顺序编号PDU。 ckjlurewioK:JFD()$#_本文来自移动通信网www.mscbsc.com,版权所有
  PID 领域价值表明倒栽跳水 压缩协议 键入使用的和小包类型或CID。 [1]

PDCP的工作原理

  分组数据汇聚协议(Packet Data Convergence Protocol,PDCP)层属于无线接口协议栈的第二层,处理控制平面上的无线资源管理(RRC)消息以及用户平面上的因特网协议(IP)包。在用户平面上,PDCP子层得到来自上层的IP数据分组后,可以对IP数据分组进行头压缩和加密,然后递交到RLC子层。PDCP子层还向上层提供按序提交和重复分组检测功能。在控制平面,PDCP子层为上层RRC提供信令传输服务,并实现RRC信令的加密和一致性保护,以及在反方向上实现RRC信令的解密和一致性检查。wioK:JFD()$#_本文来自移动通信网www.mscbsc.com,版权所有
 PDCP子层功能45%#(么K:JFD()本文来自移动通信网www.mscbsc.com,版权所有

PDCP子层的主要功能

  PDCP子层的主要功能如图1所示。    PDCP实体的结构
�$*@#(_K:JFD()本文来自移动通信网www.mscbsc.com,版权所有
PDCP协议包括以下具体支持的功能: 0874*$#(*)#$K:JFD()$#_*(本文来自移动通信网www.mscbsc.com,版权所有
  (1)用户平面数据的报头压缩和解压缩。 kcvmmvckK:JFD()$本文来自移动通信网www.mscbsc.com,版权所有
  (2)安全性功能: s1fads睰:JFD()本文来自移动通信网www.mscbsc.com,版权所有
  ①用户和控制平面协议的加密和解密; &)*(&#*(K:JFD()$本文来自移动通信网www.mscbsc.com,版权所有
  ②控制平面数据的完整性保护和验证。 354afd5a4K:JFD()$#本文来自移动通信网www.mscbsc.com,版权所有
  (3)数据的传输功能: 4f8e342是K:JFD()$#本文来自移动通信网www.mscbsc.com,版权所有
  ①下层重建时,对向上层发送的PDU顺序发送和重排序; �*&#%kcvmK:JFD()$#本文来自移动通信网www.mscbsc.com,版权所有
  ②对映射到AM模式的RB的下层SDU进行重排序。 �)$#@3221aK:JFD()$#_本文来自移动通信网www.mscbsc.com,版权所有
  (4)数据包的丢弃。

1.1 报头压缩

  在LTE系统中,规定PDCP子层支持由IETF(互联网工程任务组)定义的健壮性报头压缩协议(ROHC)来进行报头压缩。在LTE中,因其不支持通过电路交换域(CS)传输的语音业务,为了在分组交换域(PS)提供语音业务且接近常规电路交换域的效率,必须对IP/UDP/RTP报头进行压缩,这些报头通常用于VoIP业务。
  典型的,对于一个含有32 B有效载荷的VoIP分组传输来说,IPv6报头增加60 B,IPv4报头增加40 B,即188%和125%的开销。 )#$@&%#K:JFD()本文来自移动通信网www.mscbsc.com,版权所有
  为了解决这个问题,在LTE系统中,设定在激活周期内PDCP子层采用ROHC报头压缩技术,在压缩实体初始化之后,这一开销可被压缩成4~6个字节,即12.5%~18.8%的相对开销,从而提高了信道的效率和分组数据的有效性。 321%$#(*$#K:JFD()$#_本文来自移动通信网www.mscbsc.com,版权所有
  IETF在“RFC 4995”中规定了一个框架,ROHC框架中有多种头压缩算法,称为Profile,每一个Profile与特定的网络层、传输层和更上层的协议相关,如TCP/IP和RTP/UDP/IP等。具体的报头压缩协议及属性如表1所示。 ouierpoejK:JFD()$#本文来自移动通信网www.mscbsc.com,版权所有
  
afd5aK:JFD本文来自移动通信网www.mscbsc.com,版权所有
  报头压缩协议可以产生两种类型的输出包:
  (1)压缩分组包,每一个压缩包都是由相应的PDCP SDU经过报头压缩产生的; itre4K:JFD本文来自移动通信网www.mscbsc.com,版权所有
  (2)与PDCP SDU不相关的独立包,即ROHC的反馈包。
  压缩包总是与相应的PDCP SDU采用相同的PDCP SN和COUNT值;ROHC反馈包不是由PDCPSDU产生的,没有与之相关的PDCP SN,也不加密。

1.2 安全性功能

  LTE的安全性是在PDCP层负责的,通过加密(控制平面RRC数据和用户平面数据)及完整性保护(仅控制平面数据)实现。
  1.2.1 加密/解密
  
在LTE系统中,加密功能位于PDCP实体中,加密对象包括: K:JFD(本文来自移动通信网www.mscbsc.com,版权所有
  (1)控制平面,被加密的数据单元是PDCP PDU的数据部分(未压缩的用户面或控制面的PDCP SDU或压缩的用户平面PDCP SDU)和MAC—I域(完整性消息鉴权码)。
  (2)用户平面,被加密的数据单元是PDCP PDU的数据部分。 jhfjoK:JFD本文来自移动通信网www.mscbsc.com,版权所有
  PDCP实体所使用的加密算法和密钥(KEY)由高层协议配置。一旦激活安全功能,加密功能即被高层激活,该功能应用于高层指示的所有PDCP PDU。PDCP用于加密的参数包括以下2个:COUNT;DIRECTION(传输的方向)。 瞗12dsfds1K:JFD()$#_本文来自移动通信网www.mscbsc.com,版权所有
  RRC协议提供给PDCP加密功能所需要的参数包括以下2个:BEARER;KEY(控制平面使用KRRCenc,用户平面使用KUPenc)。
  加密是通过对消息和加密流做异或(XOR)运算来实现的,这里加密流是由基于接入层(AS)导出密钥、无线承载ID、传输方向(上行或下行)以及COUNT值的加密算法所生成的。加密仅适用于PDCP数据PDU。控制PDU(如ROHC反馈或PDCP状态报告)既不使用加密,也不适用完整性保护。
  1.2.2 完整性保护
  
完整性保护功能包括完整性保护和完整性验证两个过程,完整性保护功能仅应用于SRB。用于PDCP实体的完整性保护功能的算法和KEY由上层配置。一旦激活安全功能,完整性保护功能即被高层激活,该功能应用于高层指示的所有PDCP PDU。PDCP用于完整性保护的参数包括以下2个:COUNT;DIREC-TION(传输的方向)。
  RRC协议提供给PDCP完整性保护功能的参数包括以下2个:BEARER;KEY(控制平面使用KRRCint)。 a21fd3s1fdK:JFD()$#_本文来自移动通信网www.mscbsc.com,版权所有
  UE基于上述输入的参数计算X-MAC,进行PDCP PDU的完整性验证。如果计算出的X-MAC与MAC-I相同,则完整性保护验证成功。

1.3 数据的传输

  控制平面的PDCP PDU和用户平面的PDCP数据PDU都拥有一个序列号SN字段,PDCP子层的发送和接收实体就是通过设置和检查SN字段来实现PDCPPDU的按序发送和接收。PDCP子层在发送侧和接收侧分别维护一个重排序窗口的大小是SN范围的50%。当SN为0~4 095时,即“最大PDCP SN”的值为4 095时,重排序窗口的大小为2 048。 d3s1fd知1K:JFD()$#本文来自移动通信网www.mscbsc.com,版权所有
  在非切换状态下,RLC子层位为PDCP子层提供按序提交和重复包丢弃服务。而在切换状态下,由于UE与两个eNodeB同时通信,因此其RLC子层无法保证按序提交和重复包丢弃,从而需要由PDCP子层来完成这些功能。 erpoej道hK:JFD()$#本文来自移动通信网www.mscbsc.com,版权所有
  下面以UE侧的操作为例说明PDCP子层的发送和接收流程。 dsaf12zcv545K:JFD()$#_*(本文来自移动通信网www.mscbsc.com,版权所有
  1.3.1 上行发送 s13东oitreK:JFD()$#_本文来自移动通信网www.mscbsc.com,版权所有
  
每一个PDCP SDU对应一个Discard Timer,一旦由高层接收到一个PDCP SDU,即启动该SDU对应的Discard Timer。同时,进行发送相关的状态变量更新及加密、完整性保护等,具体过程如图2所示。 42是43K:JFD(本文来自移动通信网www.mscbsc.com,版权所有
   数据上行流程图5a4f8e342是4K:JFD()$#_*(本文来自移动通信网www.mscbsc.com,版权所有
5a4f8e3K:JFD()本文来自移动通信网www.mscbsc.com,版权所有
  1.3.2 下行接收 �434321%$#(*K:JFD()$#_*(本文来自移动通信网www.mscbsc.com,版权所有
  
在不需重建的普通工作模式下,PDCP实体在接收到RLC AM实体提交的PDCP PDU时,不需执行重排序过程,因为RLC AM在向PDCP实体提交PDCPPDU时,已保证顺序递交。以切换引起的PDCP重建为例,UE先从源eNodeB收到一些PDCP SDU,重建开始后从目的eNodeB接收PDCP SDU(其中部分是源eNodeB转给目的eNodeB的,并且有一些是源eNodeB已发给UE但尚未得到确认的),因此,UE的PDCP实体收到的PDCP SDU可能是乱序并且有重复的,因此对于RLC AM模式,在重建情况下,PDCP接收实体需对接收的PDCP SDU进行重排序和重复检测。 v545%#(K:JFD()本文来自移动通信网www.mscbsc.com,版权所有
  综合上述各种情况,对映射到RLC AM模式的DRB接收处理过程如下:定义接收的PDCP序列号为SN,接收端上一次提交给高层的PDCP SDU序列号为Last_Submitted_PDCP_RX_SN,Reordering_Window为序列号空间50%长度的重排序窗,RX_HFN为接收端当前HFN,Next_PDCP_RX_SN为接收端期待的下一个接收的PDCP序列号,具体流程如图3所示。
  *($(哦*&#K:JFD()$#本文来自移动通信网www.mscbsc.com,版权所有

希望能帮助你
(我)$#@3221K:JFD()$#_*本文来自移动通信网www.mscbsc.com,版权所有
回答者:xhy1331 回答时间:2012-04-23 15:32
联系我们 - 问通信专家 Powered by MSCBSC 移动通信网  © 2006 -